Fresenius 5008s De grease leak

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Fresenius 5008s De grease leak

Richard Brownlee
Hi all

Anyone else having problems with the machine leaking profusely from the port at the back of the machine when going through the de-grease programme?.  We only have this issue with new 5008s machines that we purchased last year and find that changing S01 solves the problem.  We don't have this issue with any other machines and not during heat just de-grease.

Cheers
Reply | Threaded
Open this post in threaded view
|

Re: Fresenius 5008s De grease leak

Ian Wilde
Administrator
Hi Richard,

We've haven't any machines new enough to compare for you unfortunately. Our newest 5008s is about 3 years old but I haven't seen that problem before. Is it the same outcome when you do a front fill degrease too? Just curious!

Would seem strange that s01 works correctly at other times though if it was knackered?  

May be worth seeing if Fresenius will provide you enough of them for you to do a batch replacement for any of your machines with that build code?  Have you had any feedback from them about it?

Worth asking the question if you haven't already.
Ian Wilde
Renal Tech
Manchester University NHS Foundation Trust
Reply | Threaded
Open this post in threaded view
|

Re: Fresenius 5008s De grease leak

Chris Bates
Hi,
There was a mod kit M47976 years ago to fit 2 new injector nozzles to stop this happening. Haven't seen it since.
Our newest 'S' machines are 12 months old - EC code 1535.